How do I change my NMIS server timezone?

 
3
2
1

I cannot seem to find it in the support documentation - my windows in NMIS show the right day and time, but the top right bar shows a day ahead (AEST) and I cannot seem to figure out where to change that,

    CommentAdd your comment...

    3 answers

    1.  
      3
      2
      1

      mark documented the low-level/hardcore way of achieving this, but OS software updates may very well overwrite your changes and you should consider higher-level tools where possible:

      if your server OS is Debian/Ubuntu, please use sudo dpkg-reconfigure tzdata.

      If your server OS is CentOS/RedHat 6 or older there's no generic highlevel method.
      On CentOS/RedHat 7 you should use sudo timedatectl set-timezone <new_time_zone>.

      CommentAdd your comment...
    2.  
      4
      3
      2

      Input the following command in your terminal:

      As you see, the NMIS VM uses the AEST (Eastern Australia) timezone by default. If your NMIS server(s) are all in one timezone you can use the local timezone. However, as a general practice Opmantek recommends using UTC, especially when using multiple polling servers across 1 or more timezones.

      You can see a list of possible timezones in:

      To change your server's timezone to UTC first remove the existing setting, then symlink the new setting to the localtime folder

       

      Regards,

      Mark H

       

        CommentAdd your comment...
      1.  
        1
        0
        -1
          CommentAdd your comment...