1
0
-1

Hi,

I've updated our Open Audit community edition to 2.3.1. The OSX auditing script runs fine. However, the INSERT SQL query fails.

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Pro (15-inch, 2018), 'laptop', 'laptop', '', '<hostname>', '', 'production', '1' at line 1</p><p>/* M_device::insert */ INSERT INTO system ( uuid, hostname, type, os_group, os_family, os_name, os_version, serial, model, manufacturer, os_bit, memory_count, processor_count, os_installation_date, last_seen_by, discovery_id, domain, fqdn, last_seen, description, class, form_factor, id, name, ip, status, org_id, location_id) VALUES ('<UUID>', '<hostname>', 'computer', 'Apple', 'Apple OSX', 'OSX 10.13.6', '10.13.6', '<serial number>', 'MacBookPro15,1', 'Apple Inc', '64', '16777216', ' 1', '2018-12-18 16:41:48', 'audit', '', '', '', '2018-12-21 14:45:43', MacBook Pro (15-inch, 2018), 'laptop', 'laptop', '', '<hostname>', '', 'production', '1', '1')</p><p>Filename: models/m_device.php</p><p>Line Number: 1116</p>

    CommentAdd your comment...

    5 answers

    1.  
      1
      0
      -1

      Apologies for the inconvienence, the fix is detailed here - Errata - 2.3.1 OSX Auditing

        CommentAdd your comment...
      1.  
        1
        0
        -1

        Hi,

        I'm running OpenAudit CE 2.3.1 on Debian linux 9.6. I ran the script version 2.3.0 on a Mojave 10.14.2. I'm inserting the result file. As far as I can tell, the value that is not between quotes is taken from some OA CE internal database because I cannot find it in the audit result file. 

         

          CommentAdd your comment...
        1.  
          1
          0
          -1

          Hi Ioan,

          I have both run the audit script manually and then uploaded it into Open-AudIT, as well as run a discovery upon a Mac (which included running the audit script). Both worked as intended.

          Can you shed any further light on what steps you performed to see this error message?

          Mark Unwin.

            CommentAdd your comment...
          1.  
            1
            0
            -1

            Hello Loan,

            We cannot replicate this issue in our lab. Could you please share the detailed steps to replicate this issue?

            Best,

            Mark H

              CommentAdd your comment...
            1.  
              1
              0
              -1

              Hello Loan,

              Thank you for bringing this issue to our attention. I have opened a support ticket with our development team. We will attempt to duplicate the issue, and if we can determine the cause and a fix. If it can be patched we will post it here.

              Best,

              Mark H

                CommentAdd your comment...