Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Summary

NMIS8 uses the RRDTool time series database tool for data storage and graphing, when . When RRDTool has to represent very small or very large numbers are represented , it will use units instead of showing many decimal places.  The following table summarises those units.

...

So in the chart below the little m in this case is 100m to 900m milliseconds is in fact 0.1 to 0.9 milliseconds.

 

 

 

 

...

Customization

If you find this feature undesirable you can adjust the relevant graph definitions to NOT use unit autoscaling. Find the graph file you want to adjust in /usr/local/nmis8/models, and open it with an editor. Locate the options section, and add the "--unit-exponent" setting to both standard and small graph definitions, like in the example below:

Code Block
# ... header lines
%hash = (
# ...
   'option' => {
       'standard' => [
           '--units-exponent','0',
           'DEF:ifInUcastPkts=$database:ifInUcastPkts:AVERAGE',
# ... lots of graph definition statement lines
		],
        'small' => [
            '--units-exponent','0',
            'DEF:ifInUcastPkts=$database:ifInUcastPkts:AVERAGE',
# ...