Child pages
  • Product Compatibility

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

ProductProduct VersionNMIS VersionMongoDB Version
(bold: recommended)
Notes
opConfig 2.2.0>= 8.5.0, <= 8.5.8G2.4

opConfig 2.2.0 won't be able to report config

changes to NMIS if you run it with NMIS 8.5.10G

opConfig2.2.2, 2.2.4>= 8.5.10G2.4, 2.6 or 3.0 - 3.4
 
opConfig3.0.0>= 8.5.10G2.4, 2.6 or 3.0 - 3.4

To provide compatilibity with MongoDB 2.4 you have to set the

configuration option db_use_v26_features to "false" or 0 (in conf/opCommon.nmis)

opConfig3.0.3, 3.0.4>= 8.5.10G2.6, 3.0 - 3.4 
opHA2.1.2>= 8.5.0, <= 8.5.8GN/A

opHA 2.1.2 won't be able to transfer NMIS event statuses

if you run it with NMIS 8.5.10G

opHA2.1.4>= 8.5.10GN/A 
opExport1.6.7>= 8.5.0, <= 8.5.8GN/A 
opExport1.6.8>= 8.5.10GN/A 
opFlow2.5.1>= 8.5.0, <= 8.5.8G2.4 
opFlow2.5.2>= 8.5.10G2.4, 2.6, 3.0 - 3.4 
opFlow3.0.0 - 3.0.5>=8.5.63.0 - 3.4WiredTiger storageEngine is HIGHLY recommended
opFlow3.0.6N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended.
opFlow3.0.8N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended.
opFlow3.0.10N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended. For remote integration opCharts >= 3.0.6 required
opFlowSP3.0.2N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended. For local opCharts button to agent/interface version >= 3.0.10 is required
opEvents1.2.4>= 8.5.02.4 
opEvents1.2.6, 2.0.0>= 8.5.10G2.4, 2.6, 3.0 - 3.4 
opEvents2.0.2>= 8.5.10G2.6, 3.0 - 3.4With MongoDB older than 2.6 the events table on the dashboard page will be empty.
opEvents2.0.3 - 2.0.6>= 8.5.10G2.4, 2.6, 3.0 - 3.4To provide compatilibity with MongoDB 2.4 you have to set the
configuration option db_use_v26_features to "false" or 0 (in conf/opCommon.nmis)
opEvents2.2.0 - 2.4.0>= 8.5.10G2.6, 3.0 - 3.4 
opReports3.0.2 - 3.0.8>= 8.5.0N/A 
opReports3.0.10 - 3.0.14>=8.6.0N/ADisplay names are not supported if you use older versions of NMIS
opReports3.1.0>=8.6.2N/A 
opCharts2.4.12>= 8.5.6GN/A 
opCharts2.6.2>= 8.5.6GN/AopCharts works best with NMIS 8.5.10G
opCharts3.0.0 - 3.0.7>= 8.5.6G2.6, 3.0 - 3.4opCharts works best with NMIS 8.5.10G or newer
opCharts3.0.8>= 8.5.10G2.6, 3.0 - 3.4 
opCharts3.0.10>= 8.5.10G2.6, 3.0 - 3.4 
opCharts3.2.0>= 8.5.10G3.0 - 3.4At and above opCharts 3.2 Mongo 3 is required
opCharts3.2.4 - 3.2.5>= 8.6.23.0 - 3.4 
opTrend1.2.1>= 8.5.6G,
<= 8.5.8G
2.4

opTrend's config optrend_process_condition_in_nmis must

be disabled if you run this version with NMIS 8.5.10G

opTrend1.2.3>= 8.5.10G2.4, 2.6, 3.0 - 3.4 
opAddress1.0.4> 8.5.02.4 
opAddress1.0.5>= 8.5.10G2.4, 2.6, 3.0 - 3.4 
opMaps

2.2.1

>= 8.4.8G

N/AWorks with any NMIS running .nmis files, i.e. if use_json is nonexistent or set to false
opMaps2.2.4>= 8.5.0GN/A