Child pages
  • Apache 2.4 on CentOS 6.9

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Table of Contents

Purpose

CentOS 6.9 users may have noticed that the default Apache version using yum is 2.2.  For our CentOS 6.9 users that would like to leverage the features of Apache 2.4 we offer the following advice.

Procedure

softwarecollections.org maintains a CentOS rpm for apache 2.4.  The steps that follow will utilize this repository.

https://www.softwarecollections.org/en/scls/rhscl/httpd24/

Step #1

Remove Apache 2.2

Code Block
yum remove httpd
### move the configuration directory out of the way
mv /etc/httpd /etc/httpd.22

Step #2

Install Software collections from the CentOS SCLo SIG.

Code Block
yum install centos-release-scl

Step #3

Install and enable Apache 2.4

Code Block
yum install httpd24
scl enable httpd24 bash
ln -s /opt/rh/httpd24/root/etc/httpd /etc/httpd

Step #4

Configure Apache 2.4 for NMIS and Opmantek applications.  Contact support@opmantek.com for the current 04omk-proxy.conf file.

Code Block
/usr/local/nmis8/bin/nmis.pl type=apache24 > /etc/httpd/conf.d/nmis.conf
cp apache2.4_version_04omk-proxy.conf /etc/httpd/conf.d/04omk-proxy.conf

Step #5

Configure the Apache 2.4 service to automatically start at boot time; and start the service.

...