The table below describes which combinations of Opmantek products are tested and work well with what versions of NMIS and MongoDB.
Please note that MongoDB 3.6 is not supported by Opmantek applications at this time.

 NMIS


NMIS Documentation

NMIS 8 compatibility list: 

NMIS Version

MongoDB Version
(bold: recommended)

Operating

Systems

Notes
8.6.8N/A
  • Debian 7, 8
  • Ubuntu 16
  • CentOS 7*
  • RHEL 7*

If install of NMIS 8 fails due to failure to install package WWW::Mechanize, pre-install WWW::Mechanize before installing NMIS:

  • sudo yum install -y perl-CPAN;
    sudo yum install -y perl-App-cpanminus;
    sudo cpanm WWW::Mechanize --sudo --notest;

*NB CentOS 6 and RHEL 6 are supported for existing customers who purchased support prior to 2020.

NMIS 9 compatibility list: 

NMIS Version

MongoDB Version
(bold: recommended)

Operating

Systems

Notes
> 9.0.03.4
  • Debian 9, 10*
  • Ubuntu 18, 20
  • CentOS 7**
  • RHEL 7
  • RHEL 8

RHEL 8 is supported from NMIS version 9.2.1G

On Debian 8, a compatible version of MongoDB Perl Driver (version 1.2.3 or newer) cannot be installed, even when CPANM is used.
On Ubuntu 16.04, pre-installing cpanminus, MongoDB Perl Driver and Mojo::File allows for a clean install of NMIS9:

  • apt-get install build-essential cpanminus;
  • cpanm --sudo MongoDB;
  • cpanm --sudo Mojo::File;

If install of NMIS 9 fails due to failure to install package WWW::Mechanize, pre-install WWW::Mechanize before installing NMIS:

  • sudo yum install -y perl-CPAN;
    sudo yum install -y perl-App-cpanminus;
    sudo cpanm WWW::Mechanize --sudo --notest;

Release 9.0.4 of NMIS introduces the smarter non-interactive installation mode.

*Should Debian 10 install fail with this error, 
'The following signatures couldn't be verified because the public key is not available: NO_PUBKEY',
please run the following commands to install the needed GPG Keys and reinstall:

sudo -i
type wget >/dev/null 2>&1 && GIMMEKEY="wget --tries=5 -q -T 20 -O - https://ftp-master.debian.org/keys/archive-key-8.asc" || GIMMEKEY="curl --retry 4 -L -s -m 20 https://ftp-master.debian.org/keys/archive-key-8.asc";
$GIMMEKEY | apt-key add -||$GIMMEKEY | apt-key add -||$GIMMEKEY | apt-key add -;

**CentOS 8 support has been withdrawn due to CentOS 8 being end of maintenance in 31 Dec 2021, your CentOS target should be CentOS 7 https://wiki.centos.org/About/Product

Opmantek Installer


Some notes that are common for all Opmantek Applications: 


 Open-AudIT


Open-AudIT Documentation.

ProductProduct Version

NMIS Version

Database

Operating

Systems

Notes
Open-AudIT3.3.1N/AMariaDB
  • Windows Server 2016 and up
  • CentOS 7**
  • RHEL 7
  • RHEL 8
  • Debian 9 and up*
  • Ubuntu 18.04 and up

64bit systems only. More information.
RHEL 8 is supported from Open-AudIT version 4.1.1

*Should Debian 10 install fail with this error, 
'The following signatures couldn't be verified because the public key is not available: NO_PUBKEY',
please run the following commands to install the needed GPG Keys and reinstall:

sudo -i
type wget >/dev/null 2>&1 && GIMMEKEY="wget --tries=5 -q -T 20 -O - https://ftp-master.debian.org/keys/archive-key-8.asc" || GIMMEKEY="curl --retry 4 -L -s -m 20 https://ftp-master.debian.org/keys/archive-key-8.asc";
$GIMMEKEY | apt-key add -||$GIMMEKEY | apt-key add -||$GIMMEKEY | apt-key add -;

**CentOS 8 is not supported due to CentOS 8 being end of maintenance in 31 Dec 2021, your CentOS target should be CentOS 7 https://wiki.centos.org/About/Product


 opConfig


opConfig Documentation

opConfig 2.X 3.X compatibility list: 

Product Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
 2.2.0>= 8.5.0, <= 8.5.8G2.4

opConfig 2.2.0 won't be able to report config

changes to NMIS if you run it with NMIS 8.5.10G

2.2.2, 2.2.4>= 8.5.10G2.4, 2.6 or 3.0 - 3.4

3.0.0>= 8.5.10G2.4, 2.6 or 3.0 - 3.4

To provide compatilibity with MongoDB 2.4 you have to set the

configuration option db_use_v26_features to "false" or 0 (in conf/opCommon.nmis)

3.0.3, 3.0.4>= 8.5.10G2.6, 3.0 - 3.4


opConfig 4.X compatibility list: 

Product Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
4.0.0> 9.0.0 3.4

NMIS needs to be installed but doesn't need to be running. 

Please check the opConfig 4 release notes for a specific NMIS minor version requirement. 

>4.1.1>9.1.03.4

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opHA


opHA Documentation.

opHA 2.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opHA2.1.2>= 8.5.0, <= 8.5.8GN/A

opHA 2.1.2 won't be able to transfer NMIS event statuses

if you run it with NMIS 8.5.10G

opHA2.1.4>= 8.5.10GN/A

opHA 3.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opHA>= 3.0.0 >= 9.0.03.4

Please check the opHA 3 release notes for a specific NMIS minor version requirement. 

opHA>3.1.2>9.1.03.4

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opEvents


opEvents Documentation.

opEvents 1.X & 2.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opEvents1.2.4>= 8.5.02.4
opEvents1.2.6, 2.0.0>= 8.5.10G2.4, 2.6, 3.0 - 3.4
opEvents2.0.2>= 8.5.10G2.6, 3.0 - 3.4With MongoDB older than 2.6 the events table on the dashboard page will be empty.
opEvents2.0.3 - 2.0.6>= 8.5.10G2.4, 2.6, 3.0 - 3.4To provide compatilibity with MongoDB 2.4 you have to set the
configuration option db_use_v26_features to "false" or 0 (in conf/opCommon.nmis)
opEvents2.2.0 - 2.4.0>= 8.5.10G2.6, 3.0 - 3.4

opEvents 3.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opEvents>= 3.0.0 > 9.0.03.4

NMIS needs to be installed but doesn't need to be running. 

Please check the opConfig 4 release notes for a specific NMIS minor version requirement. 

opEvents>3.1.0>9.1.03.4

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opCharts


opCharts Documentation.

opCharts 2.X & 3.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opCharts2.4.12>= 8.5.6GN/A
opCharts2.6.2>= 8.5.6GN/AopCharts works best with NMIS 8.5.10G
opCharts3.0.0 - 3.0.7>= 8.5.6G2.6, 3.0 - 3.4opCharts works best with NMIS 8.5.10G or newer
opCharts3.0.8>= 8.5.10G2.6, 3.0 - 3.4
opCharts3.0.10>= 8.5.10G2.6, 3.0 - 3.4
opCharts3.2.0>= 8.5.10G3.0 - 3.4At and above opCharts 3.2 Mongo 3 is required
opCharts3.2.4 - 3.2.5>= 8.6.23.0 - 3.4

opCharts 4.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opCharts>= 4.0.0>= 9.0.03.4

Please check the opCharts 4 release notes for a specific NMIS minor version requirement. 

opCharts>4.1.3>9.1.03.4

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opReports


opReports Documentation.

opReports 3.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opReports3.0.2 - 3.0.8>= 8.5.0N/A
opReports3.0.10 - 3.0.14>=8.6.0N/ADisplay names are not supported if you use older versions of NMIS
opReports3.1.0>=8.6.2N/A

opReports 4.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opReports> 4.0.0 >= 9.0.11N/A

Please check the opReports release notes for a specific NMIS minor version requirement. 

opReports>4.1.1>9.1.0N/A

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opAddress


opAddress Documentation.

opAddress 1.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opAddress1.0.4> 8.5.02.4
opAddress1.0.5>= 8.5.10G2.4, 2.6, 3.0 - 3.4

opAddress 2.X Compatibility list: 

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opAddress2.0.0>= 9.2.1G3.0 - 3.4

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opFlow and opFlowSP


opFlow Documentation

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opFlow2.5.1>= 8.5.0, <= 8.5.8G2.4
opFlow2.5.2>= 8.5.10G2.4, 2.6, 3.0 - 3.4
opFlow3.0.0 - 3.0.5>=8.5.63.0 - 3.4WiredTiger storageEngine is HIGHLY recommended
opFlow3.0.6N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended.
opFlow3.0.8N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended.
opFlow3.0.10N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended. For remote integration opCharts >= 3.0.6 required
opFlowSP3.0.2N/A3.0 - 3.4NMIS is optional. WiredTiger storageEngine is HIGHLY recommended. For local opCharts button to agent/interface version >= 3.0.10 is required

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opTrend


opTrend Documentation.

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opTrend1.2.1>= 8.5.6G,
<= 8.5.8G
2.4

opTrend's config optrend_process_condition_in_nmis must

be disabled if you run this version with NMIS 8.5.10G

opTrend1.2.3>= 8.5.10G2.4, 2.6, 3.0 - 3.4

 For a list of compatible Operating Systems please check the NMIS version compatibility list


End of Life Products

 opExport


opExport Documentation.

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opExport1.6.7>= 8.5.0, <= 8.5.8GN/A
opExport1.6.8>= 8.5.10GN/A

 For a list of compatible Operating Systems please check the NMIS version compatibility list

 opMaps


opMaps Documentation.

ProductProduct Version

NMIS Version

MongoDB Version
(bold: recommended)
Notes
opMaps

2.2.1

>= 8.4.8G

N/AWorks with any NMIS running .nmis files, i.e. if use_json is nonexistent or set to false
opMaps2.2.4>= 8.5.0GN/A

 For a list of compatible Operating Systems please check the NMIS version compatibility list