2
1
0

Unable to monitor CPU utilization with NMIS 8.6.1G however it was monitoring with NMIS 8.5.8G. Please refer to below image and suggest.

 

Thanks,

 

Best Regards,

Sudanand

 

 

    CommentAdd your comment...

    5 answers

    1.  
      1
      0
      -1

      While analyzing the debug information, I found the following in the debug file.

      health/WindowsProcessor.rrd does not exist, snmp is enabled, wmi is disabled (but the WMI service was running in the Windows Server)

      I just filled at WMI username and password field and it is working.

       

      Thank you very much.

      Regards,

      Sudanand

        CommentAdd your comment...
      1.  
        2
        1
        0

        Sudanand,

         

        You can also just use snmpwalk to see if the raw data is even being received, like this:


        More: http://www.alvestrand.no/objectid/1.3.6.1.2.1.25
        Even More: http://www.ietf.org/rfc/rfc1514.txt

        Perhaps also NMIS has interpreted the wrong model,
        you can also check that the model is correct in Edit Node > Advanced Options > Model

          CommentAdd your comment...
        1.  
          2
          1
          0

          Sudanand,

          When this happens to me I run the following commands, then look through the resulting files to determine if CPU information is being collected.  Usually I'll find some clue as to what the problem is with this approach.

          Best regards,

           

          Chris

            CommentAdd your comment...
          1.  
            1
            0
            -1

            Sudanand,

            It's important that you carefully analyze the debug information that was previously prescribed.  You should be able to determine why a certain statistic is not being collected with this data.  Collecting debug data is not a fix action; it is an investigative action. 

            You may need to create a new model for the Windows 2016 server.  This link describes how to create device models:  https://community.opmantek.com/x/SwtFAQ

            Best regards,

            Chris

              CommentAdd your comment...
            1.  
              1
              0
              -1

              Thank you for your quick response.

              I have tried both of the above solution but the result is still same.

              The node is Windows Server 2016 but the model is automatically being selected as Windows Server 2012. There is no Windows Server 2016 in Advance Options>Model.

              Such type of issue hasn't seen with Linux/Unix server.

              Please suggest.

                CommentAdd your comment...