Skip to end of metadata
Go to start of metadata

How to upgrade Opmantek products to use MongoDB 4.2

Note: All Opmantek products must be upgraded to versions that support MongoDB 4.2 before upgrading MongoDB 4.2

MongoDB 4.2+ enabled versions:

  • NMIS 9.4.0
  • opAddress 2.2.0
  • opCharts 4.4.0
  • opConfig 4.4.0
  • opEvents 4.2.0
  • opHA 3.5.0
  • opReports 4.4.0

Note: opReports and Open-AudIT do not use MongoDB.


For more information on Opmantek product dependencies, please see Product Compatibility.

For more information on installing and upgrading MongoDB, see MongoDB Installation.

Opmantek upgrade documentation for MongoDB:

Ubuntu - Process for Upgrading MongoDB 3.4 Standalone to MongoDB 4.2 Standalone

CentOS/Redhat - Process for Upgrading MongoDB 3.4 Standalone to MongoDB 4.2 Standalone


  • No labels