1
0
-1

I've been doing in-place upgrades without much issues since OA2.2 on a custom WAMP setup. I recently upgraded OA community from v3.2.2 to v3.3.2 but I've been having a whole host of issues, from filtering devices by org (devices?org_id=1) to even processing xml file audits.  I used files from both GitHub and the Installer and I get the same behaviour. I reverted back to the old files (3.2.2 OA/CI) with the upgraded 3.3.2 database and the issues are gone. I'm not sure where to start the troubleshooting. I'm not sure if changes to PHP and MySQL are required from 3.2.2 for 3.3.2 

Any advice would be appreciated.

    CommentAdd your comment...

    3 answers

    1.  
      1
      0
      -1

      For a list of devices belonging to an Org, you'll need to use fully qualified table.columns names. Thus:

      http://YOUR_SERVER/open-audit/index.php/devices?system.org_id=20

      As for XML files not being processed, check your folder permissions. By default we use c:\xampp\open-audit\code_igniter\application\uploads The web server user needs to be able to read and write there.

        CommentAdd your comment...
      1.  
        1
        0
        -1

        I tested both PHP version 5.6.35 and 7.2.18 and got the same results, 3.2.2 works, 3.3.2 doesn't work.

        Attached the debug portion for a simple devices by org.

        Open-AudIT_debugHTML.zip

          CommentAdd your comment...
        1.  
          1
          0
          -1

          What is the version of PHP you're running? It shouldn't make a difference - but it might .

          Can you provide an example of a received error, along with enabling the PHP error log and sending that, for the accessioned request?

            CommentAdd your comment...