Page tree
Skip to end of metadata
Go to start of metadata

This FAQ will help you solving the most common questions in relation to upgrades of our products.

FAQ

Q: I need to know if my current applications are compatible with the newer ones, where can I found a compatibility table?

A: Our Product Compatibility page describes which combinations of Opmantek products are tested and work well with what versions of NMIS and MongoDB.


Q: I'm not sure if I should upgrade, what can help me to decide?

A: We have put together a useful diagram that will help you to decide: Upgrading Opmantek Applications#UpgradeDecisionSupport

Upgrade from NMIS 8 products to NMIS 9 products

Q: How do I upgrade from NMIS 8 and NMIS 8 products to NMIS 9 and NMIS 9 products?

A: Upgrading NMIS 8 to NMIS 9  is a pretty straight forward process. However, upgrading from NMIS 8 apps to NMIS 9 apps require a bit more effort, for a complete guide on how to upgrade the application, please review: Upgrading from NMIS8 compatible applications to NMIS9 compatible applications


Q: Do I need a new licence after upgrading any of the NMIS 8 apps to NMIS 9 apps?

A: In most cases, yes, you will need to arrange a new license for this upgrade. Please contact us to check if you need a new license.

Upgrade old NMIS 8  products to newer versions

Q: Are there any compatibility issues if I'm upgrading the same type of NMIS 8 apps, from NMIS8 to NMIS8 apps?

A: Short answer is yes, but for older versions, if you have any of this versions installed on your system and want to upgrade, please refer  to this documentation: Upgrading Opmantek Applications

Application

Version

NMIS 88.7.1G or earlier version
opCharts 33.4.0 or earlier version
opConfig 3 3.4.0 or earlier version
opEvents 22.5.0 or earlier version
opHA 22.1.6 or earlier version
opReports 3 3.3.0 or earlier version
opFlow 3

3.0.16 or earlier version

opFlowSP 11.0.10 or earlier version


Q: Do I need a new licence after upgrading any of the NMIS 8 apps to a newer version?

A: Generally, there is no need to request a license update, as the licenses are continuing to be valid with this upgrade.

Upgrade old NMIS 9  products to newer versions

Q: Are there any compatibility issues if I'm upgrading the same type of NMIS 9 apps, from NMIS 9 to NMIS 9 apps?

A: Short answer is yes, but for older versions, if you have any of this versions installed on your system and want to upgrade, please refer  to this documentation: Upgrading Opmantek Applications

Application

Version

NMIS 99.1.0G or earlier version
opCharts 44.1.3 or earlier version
opConfig 4 4.1.1 or earlier version
opEvents 33.1.0 or earlier version
opHA 33.1.2 or earlier version
opReports 4 4.1.1 or earlier version


Q: Do I need a new licence after upgrading any of the NMIS 9 apps to a newer version?

A: Generally, there is no need to request a license update, as the licenses are continuing to be valid with this upgrade.

Rollback - Restore

Q: Something went wrong, I need to rollback to my previous state. What should i do?

A: All opModule installers offers the options to backup of your current /usr/local/omk before installing, if you allowed the installer to  backup up the folder, you may need to follow this procedure: Upgrading Opmantek Applications#Restoringfrombackup


  • No labels