Child pages
  • 1.12.10 Errata
Skip to end of metadata
Go to start of metadata

 

NOTE - As of 2017-01-05 (at 1400 hours Brisbane, Australia time) an updated 1.12.10 has been released that contains the below fixes (marked FIXED). The filename for this contains 1.12.10.1, but the version displayed in the application itself remains at 1.12.10. There are three further fixes below that have not been included in a newly released package as yet.

FIXED - Provide drop down org selection on device details screen.

A file has been patched since the release of Open-AudIT 1.12.10. These files will be incorporated into the next release but are available immediately for those affected.

To apply the patch, backup your current file (rename it .bak) and copy this file into place.

The default installation directory for Open-AudIT is:

Windows c:\xampplite\open-audit

Linux /usr/local/open-audit

Copy the below file to /open-audit/code_igniter/application/views/theme-bootstrap/v_devices_read.php

v_devices_read.php

FIXED - Name Match / IP Match invalid value in Enterprise

There are a couple of false positive warnings on the Enterprise Dashboard. These are safe to ignore (I changed the config item name, hence these don't exist). You can comment out lines 333 ->339 in:

Windows - c:\omk\template\oae\dashboard.html.ep

Linux - /usr/local/omk/templates/oae/dashboard.html.ep

NOTE - If you do alter the template, upon upgrade the installer will warn about checksum's not matching. Just answer the affirmative to overwrite the file anyway.

FIXED - Fix for missing data in oa_user_org

Run the below command to fix this issue.

Windows - 

Linux -

FIXED - Delete Devices not Seen for 30 Days

Modify the file open-audit/code_igniter/application/models/m_system.php and change line 1027 to the below. There is a missing right round bracket after DATE(last_seen.

 

NOTE - new patches below are not included in 1.12.10.1 patched release.

NOT FIXED - Fix for deleting items from list pages.

There is an issue in the templates for collection pages. The data-id attribute is assigned to the child element of the delete_link class assigned element. Consequently when the delete link is clicked, javascript doesn't have a valid item id for the request. The fix is to correctly place the data-id assignment on the correct element. The fix can be found in the attached file. Replace the files:

Windows - in c:\xampplite\open-audit\code_igniter\application\views\theme-bootstrap

Linux - /usr/local/open-audit/code_igniter/application/views/theme-bootstrap/

The files are the v_X_collection.php (where X is the type of collection - credentials, networks, orgs, etc) and the template file (v_template.php).

The files are below:

v_template.phpv_connections_collection.phpv_credentials_collection.phpv_fields_collection.phpv_locations_collection.phpv_networks_collection.phpv_orgs_collection.phpv_scripts_collection.php.

 

NOT FIXED - Fix for Device Attachments (2017-02-23)

There are bugs when creating, reading, updating and deleting attachments in 1.12.10.1. Add the files as below into the correct directories to fix this issue.

/open-audit/code_igniter/application/controllers/devices.php

/open-audit/code_igniter/application/controllers/main.php

/open-audit/code_igniter/application/models/m_devices.php

/open-audit/code_igniter/application/views/theme-bootstrap/v_devices_create_form_attachment.php

/open-audit/code_igniter/application/views/theme-bootstrap/v_devices_read.php

/open-audit/code_igniter/application/views/theme-tango/v_display_inc_summary.php

The files are below:

devices.phpmain.phpm_devices.phpv_devices_create_form_attachment.phpv_devices_read.phpv_display_inc_summary.php.


NOT FIXED - Snmp other than v2 not working

There is a bug in the file open-audit/code_igniter/application/helpers/snmp_helper.php that set's SNMP version always to v2.

At line 159, change the condition test from:

to

 

 

  • No labels