Child pages
  • 1.12.10 Errata
Skip to end of metadata
Go to start of metadata

 

NOTE - As of 2017-01-05 (at 1400 hours Brisbane, Australia time) an updated 1.12.10 has been released that contains the below fixes. The filename for this contains 1.12.10.1, but the version displayed in the application itself remains at 1.12.10.

Provide drop down org selection on device details screen.

A file has been patched since the release of Open-AudIT 1.12.10. These files will be incorporated into the next release but are available immediately for those affected.

To apply the patch, backup your current file (rename it .bak) and copy this file into place.

The default installation directory for Open-AudIT is:

Windows c:\xampplite\open-audit

Linux /usr/local/open-audit

Copy the below file to /open-audit/code_igniter/application/views/theme-bootstrap/v_devices_read.php

v_devices_read.php

Name Match / IP Match invalid value in Enterprise

There are a couple of false positive warnings on the Enterprise Dashboard. These are safe to ignore (I changed the config item name, hence these don't exist). You can comment out lines 333 ->339 in:

Windows - c:\omk\template\oae\dashboard.html.ep

Linux - /usr/local/omk/templates/oae/dashboard.html.ep

NOTE - If you do alter the template, upon upgrade the installer will warn about checksum's not matching. Just answer the affirmative to overwrite the file anyway.

Fix for missing data in oa_user_org

Run the below command to fix this issue.

Windows - 

Linux -

Delete Devices not Seen for 30 Days

Modify the file open-audit/code_igniter/application/models/m_system.php and change line 1027 to the below. There is a missing right round bracket after DATE(last_seen.

 

NOTE - new patches below are not included in 1.12.10.1 patched release.

Fix for deleting items from list pages.

There is an issue in the templates for collection pages. The data-id attribute is assigned to the child element of the delete_link class assigned element. Consequently when the delete link is clicked, javascript doesn't have a valid item id for the request. The fix is to correctly place the data-id assignment on the correct element. The fix can be found in the attached file. Replace the files:

Windows - in c:\xampplite\open-audit\code_igniter\application\views\theme-bootstrap

Linux - /usr/local/open-audit/code_igniter/application/views/theme-bootstrap/

The files are the v_X_collection.php (where X is the type of collection - credentials, networks, orgs, etc) and the template file (v_template.php).

The files are below:

v_template.phpv_connections_collection.phpv_credentials_collection.phpv_fields_collection.phpv_locations_collection.phpv_networks_collection.phpv_orgs_collection.phpv_scripts_collection.php.

 

 

 

  • No labels