Child pages
  • Server Requirements

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • Windows 7 and up - all must be 64bit. Windows 2008 server is our recommended operating system.
  • Linux - RedHat / CentOS 6 & 7, Debian 8 & 9, Ubuntu 1416.04 & 1618.04 - all must be 64bit.

Open-AudIT uses Apache, PHP and MySQL along with perl, vbscript, bash script and various other technologies. These are all included with your operating system or included in the downloadable Open-AudIT package. There is one exception to this, which is Nmap on Windows. Nmap must be downloaded and installed by the user. Linux versions of Open-AudIT use the Nmap package provided by the distribution which the installer will prompt you for.

...

We endeavor to support the latest and second to the latest version of the major browsers.

 


Prerequisites General

The Open-AudIT installer should take care of all required prerequisites, except for Nmap when on Windows.

...

Code Block
apt-get install mysql-server apache2 apache2-utils libapache2-mod-proxy-html libapache2-mod-php5 openssh-client php5 php5-ldap php5-mcrypt php5-mysql php5-snmp nmap zip wget curl sshpass screen smbclient logrotate libtime-modules-perl ipmitool rrdtool librrd4 libpng12-0

 


Debian 9+, Ubuntu 16.04+

Code Block
apt-get install mysql-server apache2 apache2-utils libapache2-mod-php openssh-client php php-ldap php-mbstring php-mcrypt php-mysql php-snmp php-simplexml nmap zip wget curl sshpass screen smbclient logrotate libtime-modules-perl ipmitool rrdtool librrd4 libpng12-0

 


Redhat, Centos < 7

Requires the optional Optional RPMs repo to be enabled.

...

Code Block
yum install mariadb-server httpd php php-cli php-mysql php-ldap php-mbstring php-mcrypt php-process php-snmp php-xml nmap zip curl wget sshpass screen samba-client logrotate perl-Time-modules ipmitool rrdtool libpng12