1
0
-1

Hey NMIS forum. I have just finished installing the automatic way, no manual customization. When I want to access NMIS from the Browser, its asking for a username and password. I have opened the nmis.conf, I don't see what to change to disable this.  Any one with insights?

 

 

    CommentAdd your comment...

    3 answers

    1.  
      2
      1
      0

      Hello ITFix,

      Great to see you have NMIS installed.  I will have to check the best option for disabling authentication.  Whilst I check here are some links you will find useful describing authentication.

      Firstly the default credentials so you can get past the login screen (have a look at the "NMIS WEB Users":

      Default Credentials (Passwords) for NMIS8 VM

       

      Then to understand how authentication configuration is managed in NMIS have a look here:

      User Management in NMIS8

      *** An option to disbale auth which might work is to change the authentication to "apache" and then use the apahe configuration you have tried with no auth.

      You can also learn more here:

      Configuring NMIS to use Internal Authentication

       

        CommentAdd your comment...
      1.  
        1
        0
        -1

        Hello ITFix,

        For completeness - I have done some research and it is not possible to disable the authentication completely.

          CommentAdd your comment...
        1.  
          1
          0
          -1

          Thanks Nick, I have run passed the login screen. I am happy to be on the Web UI now figuring out things down there. I am sure its best I leave the authentication alone. I just need to figure out how to created users for NMIS access. I am sure the documents on authentication that you have shared with me will lead me into the right direction.

            CommentAdd your comment...