2
1
0

I am using a fresh install of CentOS 7 minimal 1511. I set the networking, proxy, upgraded with yum and installed Perl. 

When running

I receive this error:

I cannot figure out how to get this script to run properly. I greatly appreciate your time and assistance with this issue. 

    CommentAdd your comment...

    2 answers

    1.  
      3
      2
      1

      Hi,

      Unfortunately a minimal install requires a couple of packages to get it running. Try installing the below, then re-running the installer (you already found/installed perl).

      1. James Diroff II

        Thank you for the replies. Since I had installed just the perl package, additionally installing perl-version and perl-Data-Dumper allowed the script to run. 

      CommentAdd your comment...
    2.  
      2
      1
      0

      As Mark said the Opmantek installer is written in perl - very non-demanding perl (from the perspective of dependencies) but  a few modules are required nevertheless. RedHat/Centos7 is a tad odd in that "minimal" there is really, really minimal and lacks perl altogether. Personally I'd recommend that you use

      to install a 'standard' perl environment, but just pulling in the version module and dumper should suffice.

      (We're also planning to provide an installer variation that doesn't require perl in the near future.)

        CommentAdd your comment...