I have problem in my OpenAudit Community 2.0.11 instance.

In configuration site I have set up matching record uniqueness only by "match_hostname_uuid"  and "match_uuid".

Every time when I run audit vbs, OpenAudIT creates duplicate records for each host.

In "system" table I have many duplicate "uuid" entries.

    CommentAdd your comment...

    1 answer


      Are you running Discoveries at all?

      Set the log_level config item to 7 (set back to 5 after you're done).

      Check the discovery_log on a device and it should show why it is (or isn't) matching an existing device.

      1. kristek

        After turning on logs I have entries https://imgur.com/a/w1faF In my opinion OpenAudit tries to match device by IP, but matching by IP is disabled in my configuration: https://imgur.com/a/ie6QB

      2. Mark Unwin

        That message doesn't mean it tried to match using IP, it means it couldn't find ANY matches for a device with that IP. Maybe I can reword that better. Does the XML you're submitting contain the UUID (and optionally the hostname)?

      3. kristek

        Yes, I have both - uuid and hostname in xml from computer.

      4. Mark Unwin

        What are your config options for all the match_* items?

      5. Mark Unwin

        I would set match_uuid to 'n'.

      6. Mark Unwin

        More information here - https://community.opmantek.com/display/OA/Matching+Devices Also note that if the devices are not Dell/HP/etc, they may report an identical UUID. Removing match_uuid and relying on match_hostname_uuid is likely a better option.

      7. kristek

        When I change match_hostname_uuid to "y", match_uuid to "n" and match_hostname to "n" I still have duplicate entries.

      8. Mark Unwin

        If you're using audit scripts, can you run one manually on a duplicated target (see below), and send me the system -> sys section of the XML. {code} cscript audit_windows.vbs submit_online=n create_file=y debugging=4 {code} Feel free to email it to open.audit@gmail.com

      CommentAdd your comment...